clemmy/PKGBUILD

23 lines
667 B
Bash

# Maintainer: Zergling_man, from fedora.email
#Well, it seems to work now.
pkgname=clemmy
pkgver=0.1.7
pkgrel=1
pkgdesc='A pure bash client for lemmy, with multiaccount support.'
arch=('any')
url='http://precious.harpy.faith/Zergling_man/clemmy'
license=('GPL' 'custom:plusnigger.autism.exposed')
depends=('curl' 'jq')
source=('git+http://precious.harpy.faith/Zergling_man/clemmy.git')
sha256sums=('SKIP') #Don't know how to use this on a repo.
package() {
cd ${pkgname}
install -d ${pkgdir}/usr/bin ${pkgdir}/opt/clemmy
rm README.txt
cp -r . ${pkgdir}/opt/clemmy
ln -s /opt/clemmy/clemmy.sh ${pkgdir}/usr/bin/clemmy
chmod +x ${pkgdir}/opt/clemmy/clemmy.sh
}